RSS구독하기:SUBSCRIBE TO RSS FEED
즐겨찾기추가:ADD FAVORITE
글쓰기:POST
관리자:ADMINISTRATOR
설치환경)
AIX 5.3 64bit
apache 2.2.8
php 4.4.8
oracle 10.2

참조 사이트)
http://www-03.ibm.com/systems/p/os/aix/linux/toolbox/download.html
http://www.ibm.com/developerworks/wikis/display/WikiPtype/aixopen

소스 FTP)
ftp://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/

AIX에서 apache + php + oracle 연동하기
일단 AIX에서 open source를 설치하기 위한 방법을 서술한다.
AIX에서 linux의 rpm을 쓸 수 있게 해주는 파일이 있다. 이것을 먼저 설치한다

# installp -qacXgd rpm.rte rpm.rte

설 치는 이것으로 매우 간단하게 진행된다. 이제 이것으로 AIX에서 rpm의 설치를 할 수 있게 된다. 단, AIX에 맞는 rpm을 구해야 한다. 소스FTP에 접속하면 AIX에서 사용가능한 rpm이 있으니 필요한 rpm을 다운로드 한다.

설치한 RPM 리스트
autoconf-2.59-1.aix5.1.noarch.rpm
automake-1.8.5-1.aix5.1.noarch.rpm
bash-3.2-1.aix5.2.ppc.rpm
binutils-2.14-3.aix5.1.ppc.rpm
bison-1.875-3.aix5.1.ppc.rpm
coreutils-5.2.1-2.aix5.1.ppc.rpm
cpio-2.5-1.aix5.1.ppc.rpm
diffutils-2.8.1-1.aix4.3.ppc.rpm
expat-1.95.7-4.aix5.1.ppc.rpm
expat-devel-1.95.7-4.aix5.1.ppc.rpm
flex-2.5.4a-6.aix4.3.ppc.rpm
freetype-1.3.1-9.aix5.1.ppc.rpm
freetype-demo-1.3.1-9.aix5.1.ppc.rpm
freetype-devel-1.3.1-9.aix5.1.ppc.rpm
freetype2-2.1.7-5.aix5.1.ppc.rpm
freetype2-devel-2.1.7-5.aix5.1.ppc.rpm
gawk-3.1.3-1.aix5.1.ppc.rpm
gcc-4.2.0-3.aix5.3.ppc.rpm
gcc-cplusplus-4.2.0-3.aix5.3.ppc.rpm
gd-1.8.4-3.aix5.1.ppc.rpm
gd-devel-1.8.4-3.aix5.1.ppc.rpm
gd-progs-1.8.4-3.aix5.1.ppc.rpm
gdb-6.0-1.aix5.1.ppc.rpm
gettext-0.10.40-8.aix5.2.ppc.rpm
glib-1.2.10-2.aix4.3.ppc.rpm
glib-devel-1.2.10-2.aix4.3.ppc.rpm
glib2-2.8.1-3.aix5.1.ppc.rpm
glib2-devel-2.8.1-3.aix5.1.ppc.rpm
gzip-1.2.4a-10.aix5.2.ppc.rpm
info-4.6-1.aix5.1.ppc.rpm
libgcc-4.2.0-3.aix5.3.ppc.rpm
libjpeg-6b-6.aix5.1.ppc.rpm
libjpeg-devel-6b-6.aix5.1.ppc.rpm
libpng-1.2.8-6.aix5.2.ppc.rpm
libpng-devel-1.2.8-6.aix5.2.ppc.rpm
libstdcplusplus-4.2.0-3.aix5.3.ppc.rpm
libstdcplusplus-devel-4.2.0-3.aix5.3.ppc.rpm
libtiff-3.6.1-4.aix5.1.ppc.rpm
libtiff-devel-3.6.1-4.aix5.1.ppc.rpm
libtool-1.5.8-2.aix5.1.ppc.rpm
libungif-4.1.2-1.aix5.1.ppc.rpm
libungif-devel-4.1.2-1.aix5.1.ppc.rpm
libxml2-2.6.21-3.aix5.2.ppc.rpm
libxml2-devel-2.6.21-3.aix5.2.ppc.rpm
lrzsz-0.12.20-2.aix4.3.ppc.rpm
m4-1.4.1-1.aix5.1.ppc.rpm
make-3.80-1.aix5.1.ppc.rpm
patch-2.5.4-4.aix4.3.ppc.rpm
perl-5.8.2-1.aix5.1.ppc.rpm
sed-4.1.1-1.aix5.1.ppc.rpm
tar-1.14-2.aix5.1.ppc.rpm
unzip-5.51-1.aix5.1.ppc.rpm
xpm-3.4k-7.aix5.1.ppc.rpm
xpm-devel-3.4k-7.aix5.1.ppc.rpm
zlib-1.2.3-4.aix5.2.ppc.rpm
zlib-devel-1.2.3-4.aix5.2.ppc.rpm

설치하는 방법은 리눅스와 동일하다.

rpm –ivh rpm명
rpm –Uvh rpm명

위 순서대로는 의존성이 걸릴 수도 있으니 lib류를 먼저 설치하도록 하자.
(물론, rpm –qa로 설치된 패키지도 볼 수 있다.)

설치가 끝이 났으면 컴파일러를 gcc에 맞춰준다.
export CC=gcc
export CXX=gcc

AIX의 환경변수 파일은 홈디렉토리의 .profile이니 위의 내용을 추가 한 후 적용하면 된다.

추가 환경설정내용(oracle)
export ORACLE_HOME=/oracle/app/product/102
export LIBPATH=/opt/freeware/lib:/usr/lib:/lib:/usr/css/lib:/usr/local/lib: $ORACLE_HOME/lib32:$ORACLE_HOME/lib
export LD_LIBRARY_PATH=/usr/lib:/lib:/usr/css/lib:/opt/freeware/lib:/usr/local/lib: $ORACLE_HOME /lib32: $ORACLE_HOME /lib

설치
1.  openssl
http://www.openssl.org/에서 소스를 다운 받아서 선택
./config --prefix=/app1/openssl --openssldir=/app1/openssl -fPIC shared threads

2.  apache 2.2.8(2.2.9는 소소한 버그가 있어 2.2.8을 선택)
./configure --prefix=/app1/apache --enable-modules=most --enable-so --with-ssl=/app1/openssl

3.  PHP 4.4.8(역시 소소한 버그로 인하여 4.4.8선택)
php는 openssl과 apache와는 달리 설치가 조금 다르다. 정상적으로 설치가 되진 않는다. 일단 선행작업을 조금 해주어야 한다.


oracle을 정상적으로 인식하게 하기 위한 링크작업
ln –s $ORACLE_HOME/lib32/libclntsh.a $ORACLE_HOME/lib32/libclntsh.so
ln -s $ORACLE_HOME/lib/libclntsh.a $ORACLE_HOME/lib/libclntsh.so
ln -s $ORACLE_HOME/lib32/libclntsh.a /usr/lib/libclntsh.so
ln –s $ORACLE_HOME/lib32/libclntsh.a /lib/libclntsh.so

./configure --prefix=/app1 \
--with-apxs2=/app1/apache/bin/apxs \
--with-config-file-path=/app1/apache/conf \
--with-oci8=/oracle/app/product/102 \
--with-gd \
--with-zlib-dir=/opt/freeware/lib \
--with-zlib \
--with-jpeg-dir=/opt/freeware/lib \
--with-png-dir=/opt/freeware/lib \
--with-freetype-dir=/opt/freeware/lib \
--enable-sigchild \
--enable-shared --disable-static \
--without-xpm
(설치문서를 찾던 중 --with-xpm의 옵션을 사용하면 에러가 발생 한다고하여 빼버렸다.)

 
./configure가 끝이 난 후, make 까지만 하자.
make install시에는 오류가 나며 더 이상 진행되지 않는다.
make install시 생기는오류내용

Installing PHP SAPI module:       apache2handler
/app1/apache/build/instdso.sh SH_LIBTOOL='/app1/apache/build/libtool' libphp4.la /app1/apache/modules
rm -f /app1/apache/modules/libphp4.so
/app1/apache/build/libtool --mode=install cp libphp4.la /app1/apache/modules/
cp .libs/libphp4.a /app1/apache/modules/libphp4.a
cp .libs/libphp4.lai /app1/apache/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish /data1/dunet_data/apm/php-4.4.8/libs'
chmod 755 /app1/apache/modules/libphp4.so
chmod: /app1/apache/modules/libphp4.so: No such file or directory
apxs:Error: Command failed with rc=65536
.
make: The error code from the last command is 1.

아래와 같이 해결한다.
# cp .libs/libphp4.so /app1/apache/modules/libphp4.so
# cp php.ini-dist /app1/apache/conf/php.ini
수작업으로  so 파일을 모듈에 넣어준 뒤 httpd.conf를 수정한다.

LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php .php4 .php3
AddType application/x-httpd-php-source .phps

# /app1/apache/bin/apachectl –t
Syntax OK

이렇게 하면 apapche + PHP + oci 연동이 된 것이다.
우주곰:지구곰이 아닙니다.
지구곰이 아닙니다.
Categories (190)
Information (5)
About uzoogom (5)
My Advanced Linux (73)
Learning Linux (96)
OperatingSystem (5)
Databases (4)
Tips! (1)
OpenSource (1)
«   2018/07   »
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        
  1. 2012/12 (2)
  2. 2012/04 (3)
  3. 2012/03 (6)
  4. 2012/02 (6)
  5. 2012/01 (2)